TLS Test

Security Updates

What is happening?
To ensure the integrity of connections to our websites, The Fund is removing support for TLS 1.0 and 1.1.

What is the impact?
After support for TLS 1.1 and below is removed, only browsers that support TLS 1.2 and higher will be able to access the site.

When is it happening?
During Q2 2019, The Fund will remove support for TLS 1.0 and 1.1.

How can I test if my browser is compatible?
Click the button below to test your browser. If you see an error message, your browser is not compatible.

What should I do if my browser is not compatible?
Upgrade your browser to a compatible version (see below).

Which web browsers are compatible with TLS 1.2 and higher?

  • Internet Explorer: Version 11 and newer
  • Google Chrome: Version 30 and newer
  • Firefox Mozilla: Version 27 and newer
  • Safari: Version 7 and newer
  • Chrome for Android (Android 4.0 Kitkat and newer)
  • Android OS Browser (Android 5.0 Lollipop and newer)
  • Mobile Safari

Test Your Access